using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(ol|ul)([^>]*?)(type=""[^""]*"")([^>]*?)>";
string input = @"<ol type=""a""><li></span>Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut</span><ol><li></span>aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit</span><ul type=""i""><li ></span>In voluptate velit esse type=""a"" cillum dolore eu fugiat nulla pariatur.<ol style=""abc"" type=""a"">ádasdasd
<ol style=""abc"">sadas</ol><ol style=""abc"" type=""a"" abc=""ee"">sadas</ol><ol type=""a"" abc=""ee"">sadas</ol>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}