use strict;
my $str = '<ol type="a"><li></span>Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut</span><ol><li></span>aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit</span><ul type="i"><li ></span>In voluptate velit esse type="a" cillum dolore eu fugiat nulla pariatur.<ol style="abc" type="a">ádasdasd
<ol style="abc">sadas</ol><ol style="abc" type="a" abc="ee">sadas</ol><ol type="a" abc="ee">sadas</ol>';
my $regex = qr/<(ol|ul)([^>]*?)(type="[^"]*")([^>]*?)>/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}