re = /<(ol|ul)([^>]*?)(type="[^"]*")([^>]*?)>/
str = '<ol type="a"><li></span>Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut</span><ol><li></span>aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit</span><ul type="i"><li ></span>In voluptate velit esse type="a" cillum dolore eu fugiat nulla pariatur.<ol style="abc" type="a">ádasdasd
<ol style="abc">sadas</ol><ol style="abc" type="a" abc="ee">sadas</ol><ol type="a" abc="ee">sadas</ol>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end