// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<(ol|ul)([^>]*?)(type="[^"]*")([^>]*?)>"#).unwrap();
let string = "<ol type=\"a\"><li></span>Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut</span><ol><li></span>aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit</span><ul type=\"i\"><li ></span>In voluptate velit esse type=\"a\" cillum dolore eu fugiat nulla pariatur.<ol style=\"abc\" type=\"a\">ádasdasd
<ol style=\"abc\">sadas</ol><ol style=\"abc\" type=\"a\" abc=\"ee\">sadas</ol><ol type=\"a\" abc=\"ee\">sadas</ol>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}