const regex = /<(ol|ul)([^>]*?)(type="[^"]*")([^>]*?)>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<(ol|ul)([^>]*?)(type="[^"]*")([^>]*?)>', 'g')
const str = `<ol type="a"><li></span>Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut</span><ol><li></span>aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit</span><ul type="i"><li ></span>In voluptate velit esse type="a" cillum dolore eu fugiat nulla pariatur.<ol style="abc" type="a">ádasdasd
<ol style="abc">sadas</ol><ol style="abc" type="a" abc="ee">sadas</ol><ol type="a" abc="ee">sadas</ol>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}