const regex = new RegExp('(?<={)(\\d+)(?=:)', 'gm')
const str = `{"aclList": {0: {"sequence": {1: {"counterData": "some data"`;
const subst = `"\1"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);