re = /(?<={)(\d+)(?=:)/m
str = '{"aclList": {0: {"sequence": {1: {"counterData": "some data"'
subst = '"\\1"'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result