$re = '/(?<={)(\d+)(?=:)/m';
$str = '{"aclList": {0: {"sequence": {1: {"counterData": "some data"';
$subst = "\"\1\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;