use strict;
my $str = '{"aclList": {0: {"sequence": {1: {"counterData": "some data"';
my $regex = qr/(?<={)(\d+)(?=:)/mp;
my $subst = '"\\1"';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";