# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<div class="([^"]+)">.+<div class="child-same-class">)/$1\n\t<xf:if is="\$someVariable == '$2'">...<\/xf:if>/isUg;t' <<< "<div class=\"parent-first-class\">
<div class=\"child-same-class\">
<div class=\"parent-second-class\">
<div class=\"child-same-class\">
<div class=\"parent-third-class\">
<div class=\"child-same-class\">"