using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<div class=""([^""]+)"">.+<div class=""child-same-class"">)";
string substitution = @"$1\n\t<xf:if is=""\$someVariable == '$2'"">...</xf:if>";
string input = @"<div class=""parent-first-class"">
<div class=""child-same-class"">
<div class=""parent-second-class"">
<div class=""child-same-class"">
<div class=""parent-third-class"">
<div class=""child-same-class"">";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}