const regex = new RegExp('(<div class="([^"]+)">.+<div class="child-same-class">)', 'isg')
const str = `<div class="parent-first-class">
<div class="child-same-class">
<div class="parent-second-class">
<div class="child-same-class">
<div class="parent-third-class">
<div class="child-same-class">`;
const subst = `$1\n\t<xf:if is="\$someVariable == '$2'">...</xf:if>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);