re = /(<div class="([^"]+)">.+<div class="child-same-class">)/i
str = '<div class="parent-first-class">
<div class="child-same-class">
<div class="parent-second-class">
<div class="child-same-class">
<div class="parent-third-class">
<div class="child-same-class">'
subst = '$1\\n\\t<xf:if is="\\$someVariable == \'$2\'">...</xf:if>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result