import re
regex = re.compile(r"(<div class=\"([^\"]+)\">.+<div class=\"child-same-class\">)", flags=re.IGNORECASE | re.DOTALL)
test_str = ("<div class=\"parent-first-class\">\n"
" <div class=\"child-same-class\">\n\n"
"<div class=\"parent-second-class\">\n"
" <div class=\"child-same-class\">\n\n"
"<div class=\"parent-third-class\">\n"
" <div class=\"child-same-class\">")
subst = "$1\\n\\t<xf:if is=\"\\$someVariable == '$2'\">...</xf:if>"
result = regex.sub(subst, test_str)
if result:
print(result)