# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?m)(?<=\.actionBlock\[selected\]\s*{[^{}]+?^\s*color:\s*)([^;]+);/ #FFF; \/* EDITED :$1 *\//gm;t' <<< ".actionBlock[selected] {
background-color: var(--gray11);
color: var(--gray11);
}"