$re = '/(?m)(?<=\.actionBlock\[selected\]\s*{[^{}]+?^\s*color:\s*)([^;]+);/m';
$str = '.actionBlock[selected] {
background-color: var(--gray11);
color: var(--gray11);
}';
$subst = " #FFF; /* EDITED :$1 */";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;