const regex = new RegExp('(?m)(?<=\\.actionBlock\\[selected\\]\\s*{[^{}]+?^\\s*color:\\s*)([^;]+);', 'gm')
const str = `.actionBlock[selected] {
background-color: var(--gray11);
color: var(--gray11);
}`;
const subst = ` #FFF; /* EDITED :$1 */`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);