re = /(?m)(?<=\.actionBlock\[selected\]\s*{[^{}]+?^\s*color:\s*)([^;]+);/m
str = '.actionBlock[selected] {
background-color: var(--gray11);
color: var(--gray11);
}'
subst = ' #FFF; /* EDITED :$1 */'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result