import Foundation
let pattern = #"(?m)(?<=\.actionBlock\[selected\]\s*{[^{}]+?^\s*color:\s*)([^;]+);"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
.actionBlock[selected] {
background-color: var(--gray11);
color: var(--gray11);
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = ##" #FFF; /* EDITED :$1 */"##
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)