use strict;
my $str = '.actionBlock[selected] {
background-color: var(--gray11);
color: var(--gray11);
}';
my $regex = qr/(?m)(?<=\.actionBlock\[selected\]\s*{[^{}]+?^\s*color:\s*)([^;]+);/mp;
my $subst = ' #FFF; /* EDITED :$1 */';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";