using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:\d+ ?(?:(?:year|month|week|day|hour|min(?:ute)?|sec(?:ond)?)s?|[dhMmswy]) ?)+$";
string input = @"1y 5M 2w 3d 5h 50m 50s
1 year 5M 2 weeks 3d 5 hours 50 min 50 sec
5 weeks 2 hours
50s 50 minutes
9m9m9m9m9m9m9m9m9m9m9m9m9m9m9m9";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}