// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:\d+ ?(?:(?:year|month|week|day|hour|min(?:ute)?|sec(?:ond)?)s?|[dhMmswy]) ?)+$").unwrap();
let string = "1y 5M 2w 3d 5h 50m 50s
1 year 5M 2 weeks 3d 5 hours 50 min 50 sec
5 weeks 2 hours
50s 50 minutes
9m9m9m9m9m9m9m9m9m9m9m9m9m9m9m9";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}