import re
regex = re.compile(r"^(?:\d+ ?(?:(?:year|month|week|day|hour|min(?:ute)?|sec(?:ond)?)s?|[dhMmswy]) ?)+$", flags=re.MULTILINE)
test_str = ("1y 5M 2w 3d 5h 50m 50s\n"
"1 year 5M 2 weeks 3d 5 hours 50 min 50 sec\n"
"5 weeks 2 hours\n"
"50s 50 minutes \n"
"9m9m9m9m9m9m9m9m9m9m9m9m9m9m9m9")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")