package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\d+ ?(?:(?:year|month|week|day|hour|min(?:ute)?|sec(?:ond)?)s?|[dhMmswy]) ?)+$`)
var str = `1y 5M 2w 3d 5h 50m 50s
1 year 5M 2 weeks 3d 5 hours 50 min 50 sec
5 weeks 2 hours
50s 50 minutes
9m9m9m9m9m9m9m9m9m9m9m9m9m9m9m9`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}