#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((?!([a-zA-Z0-9@._\-\/,]).*\2.*\2).)*$"
Local $sString = "This is a test" & @CRLF & _
"This isss a test" & @CRLF & _
"A testtt this is" & @CRLF & _
"Asassasasasas" & @CRLF & _
"Okay" & @CRLF & _
"Now no character is" & @CRLF & _
"allowed to appear" & @CRLF & _
"more" & @CRLF & _
"than two times"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")