$re = '/^((?!([a-zA-Z0-9@._\-\/,]).*\2.*\2).)*$/m';
$str = 'This is a test
This isss a test
A testtt this is
Asassasasasas
Okay
Now no character is
allowed to appear
more
than two times';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);