re = /^((?!([a-zA-Z0-9@._\-\/,]).*\2.*\2).)*$/m
str = 'This is a test
This isss a test
A testtt this is
Asassasasasas
Okay
Now no character is
allowed to appear
more
than two times'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end