import re
regex = re.compile(r"^((?!([a-zA-Z0-9@._\-\/,]).*\2.*\2).)*$", flags=re.MULTILINE)
test_str = ("This is a test\n"
"This isss a test\n"
"A testtt this is\n"
"Asassasasasas\n"
"Okay\n"
"Now no character is\n"
"allowed to appear\n"
"more\n"
"than two times")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")