import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?!([a-zA-Z0-9@._\\-\\/,]).*\\2.*\\2).)*$";
final String string = "This is a test\n"
+ "This isss a test\n"
+ "A testtt this is\n"
+ "Asassasasasas\n"
+ "Okay\n"
+ "Now no character is\n"
+ "allowed to appear\n"
+ "more\n"
+ "than two times";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}