using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?!([a-zA-Z0-9@._\-\/,]).*\2.*\2).)*$";
string input = @"This is a test
This isss a test
A testtt this is
Asassasasasas
Okay
Now no character is
allowed to appear
more
than two times";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}