use strict;
my $str = 'This is a test
This isss a test
A testtt this is
Asassasasasas
Okay
Now no character is
allowed to appear
more
than two times';
my $regex = qr/^((?!([a-zA-Z0-9@._\-\/,]).*\2.*\2).)*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}