use strict;
my $str = 'DTSTART;TZID=Australia/Sydney:20230206T000000
';
my $regex = qr/^(DTSTART|DTEND);[^:]+:([0-9]{8})T000[01]00/p;
my $subst = '${1};VALUE=DATE:${2}';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";