# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/ABC\h*\d+\h*DEF\h*\d+\h*GHI/слово/gm;t' <<< "1. ABC 1111111111 DEF 222222222 GHI
2. ABC 3333333 DEF 33333333 GHI
3. И т.д."