package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)ABC\h*\d+\h*DEF\h*\d+\h*GHI`)
var str = `1. ABC 1111111111 DEF 222222222 GHI
2. ABC 3333333 DEF 33333333 GHI
3. И т.д.`
var substitution = "слово"
fmt.Println(re.ReplaceAllString(str, substitution))
}