use strict;
my $str = '1. ABC 1111111111 DEF 222222222 GHI
2. ABC 3333333 DEF 33333333 GHI
3. И т.д.';
my $regex = qr~ABC\h*\d+\h*DEF\h*\d+\h*GHI~mp;
my $subst = 'слово';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";