// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)ABC\h*\d+\h*DEF\h*\d+\h*GHI").unwrap();
let string = "1. ABC 1111111111 DEF 222222222 GHI
2. ABC 3333333 DEF 33333333 GHI
3. И т.д.";
let substitution = "слово";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}