using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"ABC\h*\d+\h*DEF\h*\d+\h*GHI";
string substitution = @"слово";
string input = @"1. ABC 1111111111 DEF 222222222 GHI
2. ABC 3333333 DEF 33333333 GHI
3. И т.д.";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}