import Foundation
let pattern = #"ABC\h*\d+\h*DEF\h*\d+\h*GHI"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1. ABC 1111111111 DEF 222222222 GHI
2. ABC 3333333 DEF 33333333 GHI
3. И т.д.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"слово"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)