$re = '~ABC\h*\d+\h*DEF\h*\d+\h*GHI~m';
$str = '1. ABC 1111111111 DEF 222222222 GHI
2. ABC 3333333 DEF 33333333 GHI
3. И т.д.';
$subst = "слово";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;