package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)page(\/)*([0-9\/])*`)
var str = `themen/mein-oberfranken/sanfter-tourismus/page
themen/mein-oberfranken/sanfter-tourismus/page/2
themen/mein-oberfranken/sanfter-tourismus/page/465
themen/mein-oberfranken/sanfter-tourismus/page/465/
themen/mein-oberfranken/sanfter-tourismus/page/
themen/mein-oberfranken/sanfter-tourismus/paGe/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}