const regex = /page(\/)*([0-9\/])*/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('page(\\\/)*([0-9\\\/])*', 'gi')
const str = `themen/mein-oberfranken/sanfter-tourismus/page
themen/mein-oberfranken/sanfter-tourismus/page/2
themen/mein-oberfranken/sanfter-tourismus/page/465
themen/mein-oberfranken/sanfter-tourismus/page/465/
themen/mein-oberfranken/sanfter-tourismus/page/
themen/mein-oberfranken/sanfter-tourismus/paGe/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}