import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "page(\\/)*([0-9\\/])*";
final String string = "themen/mein-oberfranken/sanfter-tourismus/page\n"
+ "themen/mein-oberfranken/sanfter-tourismus/page/2\n"
+ "themen/mein-oberfranken/sanfter-tourismus/page/465\n"
+ "themen/mein-oberfranken/sanfter-tourismus/page/465/\n"
+ "themen/mein-oberfranken/sanfter-tourismus/page/\n"
+ "themen/mein-oberfranken/sanfter-tourismus/paGe/";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}