$re = '/page(\/)*([0-9\/])*/i';
$str = 'themen/mein-oberfranken/sanfter-tourismus/page
themen/mein-oberfranken/sanfter-tourismus/page/2
themen/mein-oberfranken/sanfter-tourismus/page/465
themen/mein-oberfranken/sanfter-tourismus/page/465/
themen/mein-oberfranken/sanfter-tourismus/page/
themen/mein-oberfranken/sanfter-tourismus/paGe/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);