// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)page(\/)*([0-9\/])*").unwrap();
let string = "themen/mein-oberfranken/sanfter-tourismus/page
themen/mein-oberfranken/sanfter-tourismus/page/2
themen/mein-oberfranken/sanfter-tourismus/page/465
themen/mein-oberfranken/sanfter-tourismus/page/465/
themen/mein-oberfranken/sanfter-tourismus/page/
themen/mein-oberfranken/sanfter-tourismus/paGe/";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}