#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d+(?:\.\d+)?k|(\d+(?:\.\d+)?)"
Local $sString = "28k ring to be worn 90w20h 96k watch final price" & @CRLF & _
"28k ring to be worn 90.8w20.6h 96k watch final price" & @CRLF & _
"28k ring to be worn 90.8 w 20.6h 96k watch final price" & @CRLF & _
"28k ring to be worn 90.8 20.6h 96k watch final price"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")