use strict;
my $str = '28k ring to be worn 90w20h 96k watch final price
28k ring to be worn 90.8w20.6h 96k watch final price
28k ring to be worn 90.8 w 20.6h 96k watch final price
28k ring to be worn 90.8 20.6h 96k watch final price';
my $regex = qr/\d+(?:\.\d+)?k|(\d+(?:\.\d+)?)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}