// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\d+(?:\.\d+)?k|(\d+(?:\.\d+)?)").unwrap();
let string = "28k ring to be worn 90w20h 96k watch final price
28k ring to be worn 90.8w20.6h 96k watch final price
28k ring to be worn 90.8 w 20.6h 96k watch final price
28k ring to be worn 90.8 20.6h 96k watch final price";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}