import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d+(?:\\.\\d+)?k|(\\d+(?:\\.\\d+)?)";
final String string = "28k ring to be worn 90w20h 96k watch final price\n"
+ "28k ring to be worn 90.8w20.6h 96k watch final price\n"
+ "28k ring to be worn 90.8 w 20.6h 96k watch final price\n"
+ "28k ring to be worn 90.8 20.6h 96k watch final price";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}