package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d+(?:\.\d+)?k|(\d+(?:\.\d+)?)`)
var str = `28k ring to be worn 90w20h 96k watch final price
28k ring to be worn 90.8w20.6h 96k watch final price
28k ring to be worn 90.8 w 20.6h 96k watch final price
28k ring to be worn 90.8 20.6h 96k watch final price`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}