re = /\d+(?:\.\d+)?k|(\d+(?:\.\d+)?)/m
str = '28k ring to be worn 90w20h 96k watch final price
28k ring to be worn 90.8w20.6h 96k watch final price
28k ring to be worn 90.8 w 20.6h 96k watch final price
28k ring to be worn 90.8 20.6h 96k watch final price'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end